Netbook Launcher now available for Maverick!

OK so yes, this looks a bit weird but hear me out. The netbook-launcher package was the old clutter based user interface for the Intrepid to Lucid netbook editions of Ubuntu, which was supplemented by the netbook-launcher-efl package that used enlightenment for anyone who didn’t have 3D. After Lucid, the code for the non-efl hasn’t been development and now everything from Maverick onwards is Unity only.

The efl package is still available, but that has it’s own problems…

I always liked the netbook-launcher, I always put it on other people’s computers (especially for the elderly who need big icons) because it filled the screen and everything was right there on the desktop. Perfect.

Screenshot of Netbook-launcher working on Maverick

It wasn’t really available in maverick until tonight, when prompted by a friend who is delivering 10 new Ubuntu computers to the local working-class community. The plan had always been to use the netbook interface and the machines won’t run Unity. So here’s where I step in, I downloaded the Lucid code for liblauncher and netbook-launcher and have fixed the gtk bitrot errors and published the results on a new PPA.

I had to change the name of the clutter package because of the hatchet job done on the netbook-launcher package to upgrade people from Lucid to Unity/Maverick. This means that when you try to install netbook-launcher, you get unity instead. That aside packages are available here:

https://launchpad.net/~doctormo/+archive/netbook-launcher/+packages

My friend probably wants to use the efl version which is still in development (by the heroic mterry no less, is there any cool project that guy isn’t involved with?). The problem with the shipped version is that it recommends the old ‘netbook-launcher’ package which pulls in unity. So I’ve built a new version of that without that dependency problem and I’ll try and get mterry to update the package for Oneric.

To use/test this branch try this:

sudo add-apt-repository ppa:doctormo/netbook-launcher
sudo apt-get update
sudo apt-get install yeold-netbook-launcher netbook-launcher-efl

I hope this ppa will be useful to a few people and do let me know below if you would like a natty version of the package…

Tags: , , , , , ,

26 Responses to “Netbook Launcher now available for Maverick!”

  1. andybleaden says:

    About time and thanks as I always thought this was a really successful system wide approach. I for one would love to see a branch for 11.04 if possible as that is what I have running. I see you have it working there on the classic gnome interface in the background…is that right? Would it work on or instead of the currentl Unity menu bar as well for netbooks?

    Anyway spot on and thanks

  2. andybleaden says:

    and by about time dont misunderstand me…I dont mean ..why has it not been done before! more like could not be better timed :)

  3. kalon33 says:

    Nice idea !

    Is a natty version planned soon ? It would be one more possibility to catch potential new users :)

    If you think there won’t be any problems with gtk or so, I could try to package it.

    Have a nice day.

    –kalon33

  4. doctormo says:

    @kalon33 – I’m talking a break from this, if you want to repackage for natty then simply give it a go (download my sources from the link in the post) and let me know if it works flawlessly. If so then I’ll do a quick resubmission, if there are issues and you can fix them, let me know by email and we can work it out too.

  5. doctormo says:

    @andy – It’s actually 10.10 gnome ‘classic’ as 11.04 doesn’t work on my laptop (still)

  6. ubuntufreak says:

    Nicely done :)
    Good thing I didn’t upgrade to Natty ;)
    I really loved netbook-launcher and was really disappointed as they discontinued it…
    Great job!!!

  7. Antanas says:

    Excellent news! One year ago I bought slightly better computer for my dad (he is nearly 80) and suggested to switch from Win98 to Ubuntu. My idea was to use Netbook-launcher because, as you right said, it has advantages for elder people. We must allways remember needs of those people.

  8. NemoInis says:

    Thank you!

  9. Brett says:

    Fantastic. I loved the old netbook launcher interface. It’s a very simple and easy to use interface that I’ve found many users pick up quickly.

  10. Derek says:

    This works great – exactly what I needed to make my systems more accessible. Thanks DoctorMO!

  11. alex12 says:

    Too bad this isn’t available for 11.04. Nice to see this though. I certainly liked this netbook interface more than Unity.

  12. [...] Owens 把这个界面移植到了 Ubuntu 10.10 Maverick 上,并制作成了 PPA 。如果你是 Ubuntu 10.10 [...]

  13. alessandro says:

    thank’s for the good work man!
    i’m actually running maverick, in the desktop session, and i can only activate the launcher by pressing alt+f2 and typing “netbook-launcher-efl”. Is that normal?
    And i cannot change the font of the categories, nor i get the effects shown in your screenshot. Am i doing something wrong?
    Thanks again :D

  14. doctormo says:

    My screenshot is using the yeold-netbook-launcher, not the efl version (2D), if your computer can do the clutter netbook-launcher, then try that.

    I fixed the package to launch the ui for any desktop user too.

  15. alessandro says:

    Maybe it’s because i’m running ubuntu in a virtual machine? If i press alt+f2 and type yeold-netbook-launcher it doesn’t apper anything…i removed anything, then added again the ppa, but the situation still the same

  16. doctormo says:

    The binary hasn’t changed names, it’s still ‘netbook-launcher’, try that.

  17. alessandro says:

    No way, the only launcher i get is the efl one, yours is pratically unaccessible, but i’m sure i have the package installed. I don’t want to stress you anymore, so maybe i’ll stay with the old plain gnome panels etc :)

  18. doctormo says:

    @alessandro – launch it from a terminal and report back what it says. It might say that it thinks your system isn’t good enough to run clutter and drops back to the efl version.

  19. alessandro says:

    It says segmentation fault (i’ve not copied the full text because it’s the third time i try to do it, and it doesn’t post anything)

  20. alessandro says:

    well, before it says
    ** (process:1675): DEBUG: OpenGL renderer string: Chromium

  21. doctormo says:

    OK that’s… very weird. Thanks for reporting the segfault, that’s on natty right?

  22. alessandro says:

    No, maverick

  23. JanC says:

    Chromium is a library implementing OpenGL on top of 1 or more underlying OpenGL implementations (either on the same PC or on multiple ones), with possibilities to filter, manipulate, distribute & convert OpenGL command streams on the fly.

    https://secure.wikimedia.org/wikipedia/en/wiki/Chromium_%28computer_graphics%29

    The VirtualBox people also use it for implementing the OpenGL-support in VirtualBox, and I remember that in the past (pre VBox 4) it didn’t implement non-official OpenGL extensions like GLX (which ubuntu-launcher/clutter uses), and maybe even today doesn’t support all of those.

  24. Arzk says:

    Sorry, was going to comment in the natty post. However, reading this made things more clear: accidentally added a wrong repo :) No point in publishing these comments.

  25. Al says:

    I love this launcher! Thank you very much for your work!!