Blackberry with OpenSync 0.40

I’ve created a new barry snapshot PPA which should be updated every 2 weeks with the latest barry git revisions and the latest opensync svn. This is to encourage testing and perhaps there is some functionality which you need in the latest versions.

I will warn you that opensync 0.4x isn’t done, isn’t safe and isn’t ready for being trusted with your data. It can duplicate entries, delete them entirely or mangle text on a whim. But it will support calendar, contact and note syncing.

Update: My PPA has been shut down because of an inability for me to test the packages. Please see the barry website for more details on how to get barry working with your Ubuntu installation.

Now that should pull in barry, opensync and your opensync 0.39 plugin. Please report back here if it works. I’ve had the devil of a time packaging all these things, almost a week worth of messing about with the packaging to get everything buildable.

If you get an error such as “E: Broken packages” then hold onto your hat, the packages are still building and taking their damn sweet time to finish. — All Fixed and built, sorry for the wait

Tags: , , , , ,

14 Responses to “Blackberry with OpenSync 0.40”

  1. bozz says:

    Pretty neat… Is there something similar but for the iPhone??

  2. doctormo says:

    I have no idea, I don’t have an iPhone… I always thought they were a bad idea.

  3. [...] Owens, más conocido como DoctorMo, ha creado Barry snapshot PPA, que no es ni más ni menos que eso, una nueva PPA para sincronizar [...]

  4. Maurizio says:

    I seguenti pacchetti hanno dipendenze non soddisfatte:
    opensync-plugin-barry-4x: Dipende: libbarry0 (= 0.17-1830-0lucid0) ma 0.15-1ubuntu2 sta per essere installato
    E: Pacchetto danneggiato

    I try to convert in english:
    dependecies non satisfied
    E: broken package
    Any hints ?

  5. Valorum says:

    This is what i got:

    $ sudo apt-get install barry-util opensync-plugin-barry-4x
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    opensync-plugin-barry-4x: Depends: libbarry0 (= 0.17-1830-0lucid0) but 0.15-1ubuntu2 is to be installed
    E: Broken packages

  6. Arrakis says:

    the same as Valorum,

    opensync-plugin-barry-4x: Dipende: libbarry0 (= 0.17-1830-0karmic0) ma 0.17-1836-0karmic0 sta per essere installato
    E: Pacchetto danneggiato

    translated from italian

    opensync-plugin-barry-4x: Dipends: libbarry0 (= 0.17-1830-0karmic0) but 0.17-1836-0karmic0 is going to be installed
    E: broken package

    any suggestion?
    Tks!

  7. SB says:

    does syncing with this new version still work via msynctool or is osynctool needed for this? in the latter case, does it work in the same way?

  8. Sam says:

    Hi, I have installed the all stuff, and it don’t work, it also don’t shows any icon for start the program and i don’t know how it suppose to work?… have any one an idea about this?.

    I dont look like be broke just don’t do anything, and the problem is that now the memory card doesn’t work anymore!

    there is missing something?

  9. doctormo says:

    Sam: The whole thing is command-line based. If you would like to test the various parts, then please do have a look at the docs for opensync and barry. But I stress that this isn’t for the new user just yet and you must be adventurous and willing to learn.

    Start with on the command line: bsync and bcharge etc. Try some man pages and have a look around.

  10. Sam says:

    doctormo: So i have to deal with the terminal for make work the app?, or just i have to read the doc that you has mentioned?

    Where can i found some more information about it?, i have the will to learn more about but i didn’t know that it would be more complicate when i did install the app.

    Do sync the BB with ubuntu would be a very usefull add, and I wish that you can do it more easy at the end.

    Thanks a lot i¿ll try to find more info about it.

  11. doctormo says:

    Sam: Making it more easy will take a lot of time for the volunteers involved. They don’t have a lot of resources to fix it.

  12. Openworld says:

    the following command : osynctool –listplugins does not list the barry plugin even after installing your package (no error). Any idea of where the problem is?

    One possible explanation : /usr/share/libopensync1 and /usr/share/opensync-0.39may be conflicting in ubuntu. One has the file barry-sync and the other one doesn’t. But copying the file didn’t solve the problem.

  13. doctormo says:

    My packages in my PPA are for the 0.4x trunk opensync, but I can no longer test if it works since I no longer have a blackberry.